{"_id":"574c1a3927b4be0e0034a774","version":{"_id":"574a3bc0d1d1381900b73fae","project":"574a3bc0d1d1381900b73fab","__v":7,"createdAt":"2016-05-29T00:45:52.939Z","releaseDate":"2016-05-29T00:45:52.939Z","categories":["574a3bc0d1d1381900b73faf","574be6d52aa7221700c51bed","574c0b6d281b010e00008f89","574c1afbcf99610e00ef7d2b","574d13b9a1f0be2000ae3803","574d14140db0870e0075382d","591eb3a72c1b1f0f000fa9f2"],"is_deprecated":false,"is_hidden":false,"is_beta":false,"is_stable":true,"codename":"","version_clean":"3517.0.0","version":"3517"},"user":"574bfb9290d8b32000864973","category":{"_id":"574a3bc0d1d1381900b73faf","version":"574a3bc0d1d1381900b73fae","project":"574a3bc0d1d1381900b73fab","__v":0,"sync":{"url":"","isSync":false},"reference":false,"createdAt":"2016-05-29T00:45:52.959Z","from_sync":false,"order":1,"slug":"documentation","title":"Introduction"},"parentDoc":null,"project":"574a3bc0d1d1381900b73fab","__v":47,"githubsync":"","metadata":{"title":"","description":"","image":[]},"updates":[],"next":{"pages":[],"description":""},"createdAt":"2016-05-30T10:47:21.853Z","link_external":false,"link_url":"","sync_unique":"","hidden":false,"api":{"results":{"codes":[]},"settings":"","auth":"required","params":[],"url":""},"isReference":false,"order":1,"body":"The software runs under 64-bit Microsoft Windows operating systems.  OSX and NIX operating systems are not supported unless they are hosting a Microsoft Windows virtual machine.  The operating system of the software can either reside on a user's physical machine or a virtual machine housed in an enterprise data-center.  In general, three basic software prerequisites are required:\n\n1. Microsoft SQL Server Express (recommended version is 2014 64-bit)\n\n2. Microsoft Excel (recommended version is Excel 2016 64-bit)\n\n3. Microsoft Windows 64-bit operating system with the Microsoft .NET Framework 3.5 feature activated.\n\n4. Recommended RAM of 8GB (with a minimum functional RAM of of 4GB)\n\n<br />\nAll applications and libraries that are required by the software are installed at the time the software is provisioned to users.  No other stand-alone software licenses or installations of third-party linear programming applications are required.\n\nThe supported operating systems are 64-bit versions of Microsoft Windows 7, Windows 8.0/8.1 and Windows 10, as well as Windows Server 2008R2, 2012 & 2012R2.  Only 64-bit operating system installations are supported and installation under Windows XP, Windows Vista, Windows Server 2003 and any 32-bit operating system is not possible.\n\nThe software can be used within a hosted desktop environment such as Citrix or Windows Remote Desktop (RDP).  The hosting data-center can be on-premises or off-premises.  A fully hosted and scalable cloud based service offering provisioned as a streaming application is available.\n<br />\n[block:api-header]\n{\n  \"type\": \"basic\",\n  \"title\": \"Software Prerequisite Requirements\"\n}\n[/block]\nThe software needs to be provisioned for the specific version of Microsoft Excel that is installed.  Before software installation is undertaken then the following information is needed:\n\n1. Is the version of Microsoft Windows that is installed a 64-bit operating system?\n\n2. Is the version of Microsoft Excel that has been installed 32-bit or 64-bit?\n\n3. Is there an existing version of Microsoft SQL Server installed on the system?\n\n4. Is the necessary Microsoft .NET Framework installed on the system?\n\n<br />\nPlease each check below to determine the status of the host operating system.  Record this information for use later with the installation process.\n<br />\n<br />\n[block:api-header]\n{\n  \"type\": \"basic\",\n  \"title\": \"Check 1 - Is the Operating System 64-bit Windows?\"\n}\n[/block]\n\n[block:callout]\n{\n  \"type\": \"danger\",\n  \"body\": \"Microsoft Windows must be 64-bit.  Tigermoth cannot be installed on a 32-bit version of Windows.\",\n  \"title\": \"Prerequisite\"\n}\n[/block]\n##WINDOWS 7\nClick the ‘Start’ button, then right-click the ‘Computer’ button and select ‘Properties’.  The Windows operating system type can be found as circled below.  Please check that the operating system is 64-bit.  Tigermoth cannot be installed on a 32-bit version of Windows.\n[block:image]\n{\n  \"images\": [\n    {\n      \"image\": [\n        \"https://files.readme.io/WXSgiT9Qi20dpjlUv3Mw_support-installation-windows7.jpg\",\n        \"support-installation-windows7.jpg\",\n        \"1699\",\n        \"956\",\n        \"#126bc2\",\n        \"\"\n      ],\n      \"sizing\": \"full\"\n    }\n  ]\n}\n[/block]\n##WINDOWS 8 & WINDOWS 10\nPress the ‘Windows Key’ + ‘X’, then select ‘System’.  The Windows operating system type can be found as circled below.  Please check that the operating system is 64-bit.  Tigermoth cannot be installed on a 32-bit version of Windows.\n\n[block:image]\n{\n  \"images\": [\n    {\n      \"image\": [\n        \"https://files.readme.io/DsTQdhz3RKGt2TYi2s1V_support-installation-windows8.jpg\",\n        \"support-installation-windows8.jpg\",\n        \"1698\",\n        \"955\",\n        \"#3d6779\",\n        \"\"\n      ],\n      \"sizing\": \"full\"\n    }\n  ]\n}\n[/block]\n<br />\n<br />\n[block:api-header]\n{\n  \"type\": \"basic\",\n  \"title\": \"Check 2 - Is Microsoft Excel a 32-bit or 64-bit Installation?\"\n}\n[/block]\n##MICROSOFT EXCEL 2007\nMicrosoft Excel 2007 is always installed as a 32-bit application on all operating systems.\n\n##MICROSOFT EXCEL 2010\nOpen ‘Excel’ and then click ‘File’ at the top left, then click ‘Help’.  The version of Microsoft Excel 2010 can be found as circled below.  Please note if Excel is 32-bit or 64-bit.  Note that Microsoft Excel 2007 is always installed as 32-bit.\n[block:image]\n{\n  \"images\": [\n    {\n      \"image\": [\n        \"https://files.readme.io/JhRbgCLQ5elKtiKS9Agv_support-installation-excel2010.jpg\",\n        \"support-installation-excel2010.jpg\",\n        \"1548\",\n        \"912\",\n        \"#436e76\",\n        \"\"\n      ],\n      \"sizing\": \"full\"\n    }\n  ]\n}\n[/block]\n##MICROSOFT EXCEL 2013 & 2016\nOpen ‘Excel’ and then click ‘File’ at the top left, then click ‘Account’, and then click ‘About Excel’.  The version of Microsoft Excel 2013 can be found as circled below.  Please note if Excel is 32-bit or 64-bit.  Note that Microsoft Excel 2007 is always installed as 32-bit. \n\n[block:image]\n{\n  \"images\": [\n    {\n      \"image\": [\n        \"https://files.readme.io/6Ae8U9tmQf2hiM7iyk6z_support-installation-excel2013.jpg\",\n        \"support-installation-excel2013.jpg\",\n        \"1490\",\n        \"793\",\n        \"#2b6b47\",\n        \"\"\n      ],\n      \"sizing\": \"full\"\n    }\n  ]\n}\n[/block]\n<br />\n<br />\n[block:api-header]\n{\n  \"type\": \"basic\",\n  \"title\": \"Check 3 - Is Microsoft SQL Server Express Installed?\"\n}\n[/block]\n##METHOD 1\nPerhaps the simplest way to determine if Microsoft SQL Server is installed is to look for the 'SQL Server Configuration Manager' entry under the 'Start/All Programs/Microsoft SQL Server [2008 R2]/Configuration Tools' location (see below).\n\n[block:image]\n{\n  \"images\": [\n    {\n      \"image\": [\n        \"https://files.readme.io/XH28tqGKQCuXTmbkvtKF_support-installation-sqlserver7.jpg\",\n        \"support-installation-sqlserver7.jpg\",\n        \"411\",\n        \"527\",\n        \"#889faf\",\n        \"\"\n      ],\n      \"sizing\": \"smart\"\n    }\n  ]\n}\n[/block]\n##METHOD 2\nMost often when Microsoft SQL Server is installed then the SQL Server Command Line Tool is available on the local machine.  The presence of this command line tool can be determined from a command prompt (see below).\n\n1. Open a DOS Command Prompt window and type  `SQLCMD -?`\n2. If the SQL Server Command Line Tool is installed then a screen like that shown below will result.\n[block:image]\n{\n  \"images\": [\n    {\n      \"image\": [\n        \"https://files.readme.io/nvn7k4UMQL6lJYA4cB6h_support-installation-sqlserver8.jpg\",\n        \"support-installation-sqlserver8.jpg\",\n        \"678\",\n        \"424\",\n        \"#285c91\",\n        \"\"\n      ],\n      \"sizing\": \"smart\"\n    }\n  ]\n}\n[/block]\nIf the Microsoft SQL Server Command Line Tool is not installed then the command won’t be recognized and the result should be an error that states “‘sqlcmd’ is not recognized as an internal or external command...”  This normally means that Microsoft SQL Server has not been installed, or is not available in the local machine's command environment.\n\nIf both Methods 1 & 2 shown on this page fail to show the presence of Microsoft SQL Server then it is likely that a new instance of Microsoft SQL Server needs to be installed as per the instructions in Step 1) on the Software Installation page.\n<br />\n<br />\n[block:api-header]\n{\n  \"type\": \"basic\",\n  \"title\": \"Check 4 - Is the Microsoft .NET Framework Installed?\"\n}\n[/block]\n\n[block:callout]\n{\n  \"type\": \"danger\",\n  \"title\": \"Prerequisite\",\n  \"body\": \"The Microsoft .NET Framework version 3.5 must be installed before Tigermoth is installed.\"\n}\n[/block]\nThe software has a current Microsoft .NET Framework prerequisite of .NET 3.5.  When using Windows 7 then this is normally always preinstalled and existing, however occasionally it is not.  When using Windows 8 or Windows 10 the .NET 3.5 framework almost always needs to be manually added.  To check if the framework is present then open the Windows Control Panel and then select \"Programs\".  From there select \"Programs and Features\" as shown below, followed by \"Turn Windows features on or off\".\n\n[block:image]\n{\n  \"images\": [\n    {\n      \"image\": [\n        \"https://files.readme.io/iWEFbjiFQhGzP68fAZBh_support-installation-programs.jpg\",\n        \"support-installation-programs.jpg\",\n        \"732\",\n        \"595\",\n        \"#455a6f\",\n        \"\"\n      ],\n      \"sizing\": \"smart\"\n    }\n  ]\n}\n[/block]\n\n[block:image]\n{\n  \"images\": [\n    {\n      \"image\": [\n        \"https://files.readme.io/VKZ9OS5tTUKmjxRWpTun_support-installation-winfeatures.jpg\",\n        \"support-installation-winfeatures.jpg\",\n        \"731\",\n        \"594\",\n        \"#c83431\",\n        \"\"\n      ],\n      \"sizing\": \"smart\"\n    }\n  ]\n}\n[/block]\nThe Windows Features dialog box will open and the first entry should be \".NET Framework 3.5 (includes .NET 2.0 and 3.0)\".  If the check box for this entry is empty then click the check box and click the \"OK\" button.  The machine will connect to the internet and download and install the necessary .NET framework prerequisites.  If the check box is already shaded as shown below then the .NET 3.5 framework is installed and no further action is required.\n[block:image]\n{\n  \"images\": [\n    {\n      \"image\": [\n        \"https://files.readme.io/P04pxBboQBC39U2trRbw_support-installation-dotnet.jpg\",\n        \"support-installation-dotnet.jpg\",\n        \"431\",\n        \"377\",\n        \"#365273\",\n        \"\"\n      ],\n      \"sizing\": \"smart\"\n    }\n  ]\n}\n[/block]","excerpt":"Software system requirements and prerequisite checks","slug":"system-requirements","type":"basic","title":"System Requirements"}

System Requirements

Software system requirements and prerequisite checks

The software runs under 64-bit Microsoft Windows operating systems. OSX and NIX operating systems are not supported unless they are hosting a Microsoft Windows virtual machine. The operating system of the software can either reside on a user's physical machine or a virtual machine housed in an enterprise data-center. In general, three basic software prerequisites are required: 1. Microsoft SQL Server Express (recommended version is 2014 64-bit) 2. Microsoft Excel (recommended version is Excel 2016 64-bit) 3. Microsoft Windows 64-bit operating system with the Microsoft .NET Framework 3.5 feature activated. 4. Recommended RAM of 8GB (with a minimum functional RAM of of 4GB) <br /> All applications and libraries that are required by the software are installed at the time the software is provisioned to users. No other stand-alone software licenses or installations of third-party linear programming applications are required. The supported operating systems are 64-bit versions of Microsoft Windows 7, Windows 8.0/8.1 and Windows 10, as well as Windows Server 2008R2, 2012 & 2012R2. Only 64-bit operating system installations are supported and installation under Windows XP, Windows Vista, Windows Server 2003 and any 32-bit operating system is not possible. The software can be used within a hosted desktop environment such as Citrix or Windows Remote Desktop (RDP). The hosting data-center can be on-premises or off-premises. A fully hosted and scalable cloud based service offering provisioned as a streaming application is available. <br /> [block:api-header] { "type": "basic", "title": "Software Prerequisite Requirements" } [/block] The software needs to be provisioned for the specific version of Microsoft Excel that is installed. Before software installation is undertaken then the following information is needed: 1. Is the version of Microsoft Windows that is installed a 64-bit operating system? 2. Is the version of Microsoft Excel that has been installed 32-bit or 64-bit? 3. Is there an existing version of Microsoft SQL Server installed on the system? 4. Is the necessary Microsoft .NET Framework installed on the system? <br /> Please each check below to determine the status of the host operating system. Record this information for use later with the installation process. <br /> <br /> [block:api-header] { "type": "basic", "title": "Check 1 - Is the Operating System 64-bit Windows?" } [/block] [block:callout] { "type": "danger", "body": "Microsoft Windows must be 64-bit. Tigermoth cannot be installed on a 32-bit version of Windows.", "title": "Prerequisite" } [/block] ##WINDOWS 7 Click the ‘Start’ button, then right-click the ‘Computer’ button and select ‘Properties’. The Windows operating system type can be found as circled below. Please check that the operating system is 64-bit. Tigermoth cannot be installed on a 32-bit version of Windows. [block:image] { "images": [ { "image": [ "https://files.readme.io/WXSgiT9Qi20dpjlUv3Mw_support-installation-windows7.jpg", "support-installation-windows7.jpg", "1699", "956", "#126bc2", "" ], "sizing": "full" } ] } [/block] ##WINDOWS 8 & WINDOWS 10 Press the ‘Windows Key’ + ‘X’, then select ‘System’. The Windows operating system type can be found as circled below. Please check that the operating system is 64-bit. Tigermoth cannot be installed on a 32-bit version of Windows. [block:image] { "images": [ { "image": [ "https://files.readme.io/DsTQdhz3RKGt2TYi2s1V_support-installation-windows8.jpg", "support-installation-windows8.jpg", "1698", "955", "#3d6779", "" ], "sizing": "full" } ] } [/block] <br /> <br /> [block:api-header] { "type": "basic", "title": "Check 2 - Is Microsoft Excel a 32-bit or 64-bit Installation?" } [/block] ##MICROSOFT EXCEL 2007 Microsoft Excel 2007 is always installed as a 32-bit application on all operating systems. ##MICROSOFT EXCEL 2010 Open ‘Excel’ and then click ‘File’ at the top left, then click ‘Help’. The version of Microsoft Excel 2010 can be found as circled below. Please note if Excel is 32-bit or 64-bit. Note that Microsoft Excel 2007 is always installed as 32-bit. [block:image] { "images": [ { "image": [ "https://files.readme.io/JhRbgCLQ5elKtiKS9Agv_support-installation-excel2010.jpg", "support-installation-excel2010.jpg", "1548", "912", "#436e76", "" ], "sizing": "full" } ] } [/block] ##MICROSOFT EXCEL 2013 & 2016 Open ‘Excel’ and then click ‘File’ at the top left, then click ‘Account’, and then click ‘About Excel’. The version of Microsoft Excel 2013 can be found as circled below. Please note if Excel is 32-bit or 64-bit. Note that Microsoft Excel 2007 is always installed as 32-bit. [block:image] { "images": [ { "image": [ "https://files.readme.io/6Ae8U9tmQf2hiM7iyk6z_support-installation-excel2013.jpg", "support-installation-excel2013.jpg", "1490", "793", "#2b6b47", "" ], "sizing": "full" } ] } [/block] <br /> <br /> [block:api-header] { "type": "basic", "title": "Check 3 - Is Microsoft SQL Server Express Installed?" } [/block] ##METHOD 1 Perhaps the simplest way to determine if Microsoft SQL Server is installed is to look for the 'SQL Server Configuration Manager' entry under the 'Start/All Programs/Microsoft SQL Server [2008 R2]/Configuration Tools' location (see below). [block:image] { "images": [ { "image": [ "https://files.readme.io/XH28tqGKQCuXTmbkvtKF_support-installation-sqlserver7.jpg", "support-installation-sqlserver7.jpg", "411", "527", "#889faf", "" ], "sizing": "smart" } ] } [/block] ##METHOD 2 Most often when Microsoft SQL Server is installed then the SQL Server Command Line Tool is available on the local machine. The presence of this command line tool can be determined from a command prompt (see below). 1. Open a DOS Command Prompt window and type `SQLCMD -?` 2. If the SQL Server Command Line Tool is installed then a screen like that shown below will result. [block:image] { "images": [ { "image": [ "https://files.readme.io/nvn7k4UMQL6lJYA4cB6h_support-installation-sqlserver8.jpg", "support-installation-sqlserver8.jpg", "678", "424", "#285c91", "" ], "sizing": "smart" } ] } [/block] If the Microsoft SQL Server Command Line Tool is not installed then the command won’t be recognized and the result should be an error that states “‘sqlcmd’ is not recognized as an internal or external command...” This normally means that Microsoft SQL Server has not been installed, or is not available in the local machine's command environment. If both Methods 1 & 2 shown on this page fail to show the presence of Microsoft SQL Server then it is likely that a new instance of Microsoft SQL Server needs to be installed as per the instructions in Step 1) on the Software Installation page. <br /> <br /> [block:api-header] { "type": "basic", "title": "Check 4 - Is the Microsoft .NET Framework Installed?" } [/block] [block:callout] { "type": "danger", "title": "Prerequisite", "body": "The Microsoft .NET Framework version 3.5 must be installed before Tigermoth is installed." } [/block] The software has a current Microsoft .NET Framework prerequisite of .NET 3.5. When using Windows 7 then this is normally always preinstalled and existing, however occasionally it is not. When using Windows 8 or Windows 10 the .NET 3.5 framework almost always needs to be manually added. To check if the framework is present then open the Windows Control Panel and then select "Programs". From there select "Programs and Features" as shown below, followed by "Turn Windows features on or off". [block:image] { "images": [ { "image": [ "https://files.readme.io/iWEFbjiFQhGzP68fAZBh_support-installation-programs.jpg", "support-installation-programs.jpg", "732", "595", "#455a6f", "" ], "sizing": "smart" } ] } [/block] [block:image] { "images": [ { "image": [ "https://files.readme.io/VKZ9OS5tTUKmjxRWpTun_support-installation-winfeatures.jpg", "support-installation-winfeatures.jpg", "731", "594", "#c83431", "" ], "sizing": "smart" } ] } [/block] The Windows Features dialog box will open and the first entry should be ".NET Framework 3.5 (includes .NET 2.0 and 3.0)". If the check box for this entry is empty then click the check box and click the "OK" button. The machine will connect to the internet and download and install the necessary .NET framework prerequisites. If the check box is already shaded as shown below then the .NET 3.5 framework is installed and no further action is required. [block:image] { "images": [ { "image": [ "https://files.readme.io/P04pxBboQBC39U2trRbw_support-installation-dotnet.jpg", "support-installation-dotnet.jpg", "431", "377", "#365273", "" ], "sizing": "smart" } ] } [/block]